# CVE-2026-117499: @fastify/session vulnerable to session revocation bypass via a logout race condition


- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-2hw7-jxfh-4rm3

## What is CVE-2026-117499?

CVE-2026-117499 is a low-severity vulnerability in @fastify/session, published on 27 Oct 2026. 

### Official description

@fastify/session is a session plugin for Fastify. In all releases before 11.1.6, with the default rolling session behavior, a request that restored a session before a logout could save its own copy after another request had completed the session destroy call, recreating the destroyed session identifier with its authenticated data. An attacker who already holds a victim's valid signed session cookie and keeps a request in flight across the logout can replay that cookie to restore the session after it was meant to be revoked, without any cookie theft or signature forgery. The issue is fixed in @fastify/session 11.1.6, which adds a per session generation marker and a conditional store write so a session restored before a logout or regeneration cannot recreate or overwrite the current entry, and users should upgrade to 11.1.6 or later. There is no workaround, and custom session stores must implement the new conditional write.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-117499?


## How do I fix CVE-2026-117499?

No fix has been published for CVE-2026-117499 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-117499 being exploited?

There is no known exploitation of CVE-2026-117499 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-117499 and fix it if it is affected.

What it is: CVE-2026-117499 is a low-severity vulnerability in @fastify/session, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-117499 in the wild and no public exploit code.

Affected product: @fastify/session. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-117499/ (Markdown: https://insights.sbomify.com/CVE-2026-117499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-117499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-117499
- OSV: https://osv.dev/vulnerability/CVE-2026-117499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-117499/
Summaries are generated and may contain mistakes; the official description above is the record.
