# CVE-2026-118242: Highcharts Grid: custom icon definition objects written with raw `setAttribute` on `<path>`


- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-6g3c-p4fg-xv47

## What is CVE-2026-118242?

CVE-2026-118242 is a high-severity vulnerability in @highcharts grid-lite, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. From 2.3.0 until 3.2.0, Highcharts Grid creates SVG path elements from rendering.icons object definitions and previously copied every child key with setAttribute. An attacker who controls Grid configuration can supply event-handler attribute names in an icon definition. Because custom icons override built-ins, the attacker can replace default sort or pagination icons, and script runs in the hosting page origin when a user hovers over or activates the affected icon. This issue is fixed in 3.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-118242?

4 open source packages ship an affected version, including @highcharts/grid-lite and @highcharts/grid-pro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@highcharts/grid-lite` | npm | From 2.3.0 | 3.2.0 |
| `@highcharts/grid-lite` | npm | From 2.3.0 | 3.2.0 |
| `@highcharts/grid-pro` | npm | From 2.3.0 | 3.2.0 |
| `@highcharts/grid-pro` | npm | From 2.3.0 | 3.2.0 |

## How do I fix CVE-2026-118242?

Upgrade @highcharts/grid-lite to 3.2.0 or later.

## Is CVE-2026-118242 being exploited?

There is no known exploitation of CVE-2026-118242 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118242 and fix it if it is affected.

What it is: CVE-2026-118242 is a high-severity vulnerability in @highcharts grid-lite, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118242 in the wild and no public exploit code.

Affected packages and fixed versions:
- @highcharts/grid-lite (npm): affected from 2.3.0; fixed in 3.2.0
- @highcharts/grid-lite (npm): affected from 2.3.0; fixed in 3.2.0
- @highcharts/grid-pro (npm): affected from 2.3.0; fixed in 3.2.0
- @highcharts/grid-pro (npm): affected from 2.3.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118242/ (Markdown: https://insights.sbomify.com/CVE-2026-118242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118242
- OSV: https://osv.dev/vulnerability/CVE-2026-118242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118242/
Summaries are generated and may contain mistakes; the official description above is the record.
