# CVE-2026-118243: Highcharts Dashboards: `__proto__` data table id writes sync listeners to `Object.prototype`


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-jqgh-w3cc-7jqw

## What is CVE-2026-118243?

CVE-2026-118243 is a medium-severity vulnerability in highcharts, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. From 1.0.0 until 4.2.2, Highcharts Dashboards stores DataCursor listener and state maps in plain objects keyed by DataTable ID. A __proto__ table ID supplied through dataPool connector configuration resolves to Object.prototype, and sync registration creates an enumerable property there whose suffix can be influenced through the sync group option. The property is visible on every object, and lasting sync states can throw and stop features such as extremes synchronization. Exploitation requires untrusted dashboard configuration and an enabled component sync, but no user interaction beyond loading the board. This issue is fixed in 4.2.2.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-118243?

2 open source packages ship an affected version, including @highcharts/dashboards.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@highcharts/dashboards` | npm | From 1.0.0 | 4.2.2 |
| `@highcharts/dashboards` | npm | From 1.0.0 | 4.2.2 |

## How do I fix CVE-2026-118243?

Upgrade @highcharts/dashboards to 4.2.2 or later.

## Is CVE-2026-118243 being exploited?

There is no known exploitation of CVE-2026-118243 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118243 and fix it if it is affected.

What it is: CVE-2026-118243 is a medium-severity vulnerability in highcharts, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118243 in the wild and no public exploit code.

Affected packages and fixed versions:
- @highcharts/dashboards (npm): affected from 1.0.0; fixed in 4.2.2
- @highcharts/dashboards (npm): affected from 1.0.0; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118243/ (Markdown: https://insights.sbomify.com/CVE-2026-118243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118243
- OSV: https://osv.dev/vulnerability/CVE-2026-118243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118243/
Summaries are generated and may contain mistakes; the official description above is the record.
