# CVE-2026-118249: Highcharts: series column construction writes to Object.prototype


- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-gfvx-2c2g-38wq

## What is CVE-2026-118249?

CVE-2026-118249 is a high-severity vulnerability in highcharts, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. From 13.0.0 until 13.1.0, Highcharts builds series data columns by using point option keys directly as column IDs. Own enumerable __proto__ and constructor keys from parsed point objects can therefore direct integer-indexed writes to Object.prototype or the Object constructor. The inherited values affect reads and for-in enumeration across the page and can disrupt rendering or alter consuming application behavior without user interaction beyond rendering the chart. This issue is fixed in 13.1.0.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-118249?

2 open source packages ship an affected version, including highcharts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `highcharts` | npm | From 13.0.0 | 13.1.0 |
| `highcharts` | npm | From 13.0.0 | 13.1.0 |

## How do I fix CVE-2026-118249?

Upgrade highcharts to 13.1.0 or later.

## Is CVE-2026-118249 being exploited?

There is no known exploitation of CVE-2026-118249 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118249 and fix it if it is affected.

What it is: CVE-2026-118249 is a high-severity vulnerability in highcharts, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118249 in the wild and no public exploit code.

Affected packages and fixed versions:
- highcharts (npm): affected from 13.0.0; fixed in 13.1.0
- highcharts (npm): affected from 13.0.0; fixed in 13.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118249/ (Markdown: https://insights.sbomify.com/CVE-2026-118249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118249
- OSV: https://osv.dev/vulnerability/CVE-2026-118249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118249/
Summaries are generated and may contain mistakes; the official description above is the record.
