# CVE-2026-118251: Highcharts: javascript: URL in credits.href runs script on click


- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-5793-x2q3-c3q7

## What is CVE-2026-118251?

CVE-2026-118251 is a high-severity vulnerability in highcharts, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. Prior to 11.4.9, 12.6.1, and 13.1.0, Highcharts assigns credits.href to the window location when the credits label is clicked without checking the URL against the allowed-scheme list. An attacker who controls chart configuration can provide a javascript URL and run script in the origin of the hosting page when a user clicks the credits label. Highcharts Stock, Maps, and Gantt are included because they ship from the same package. This issue is fixed in 11.4.9, 12.6.1 and 13.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-118251?

6 open source packages ship an affected version, including highcharts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `highcharts` | npm | All versions | 11.4.9 |
| `highcharts` | npm | All versions | 11.4.9 |
| `highcharts` | npm | From 12.0.0 | 12.6.1 |
| `highcharts` | npm | From 12.0.0 | 12.6.1 |
| `highcharts` | npm | From 13.0.0 | 13.1.0 |
| `highcharts` | npm | From 13.0.0 | 13.1.0 |

## How do I fix CVE-2026-118251?

Upgrade highcharts to a fixed version for your release line: 11.4.9, 12.6.1 or 13.1.0.

## Is CVE-2026-118251 being exploited?

There is no known exploitation of CVE-2026-118251 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118251 and fix it if it is affected.

What it is: CVE-2026-118251 is a high-severity vulnerability in highcharts, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118251 in the wild and no public exploit code.

Affected packages and fixed versions:
- highcharts (npm): affected all versions; fixed in 11.4.9
- highcharts (npm): affected all versions; fixed in 11.4.9
- highcharts (npm): affected from 12.0.0; fixed in 12.6.1
- highcharts (npm): affected from 12.0.0; fixed in 12.6.1
- highcharts (npm): affected from 13.0.0; fixed in 13.1.0
- highcharts (npm): affected from 13.0.0; fixed in 13.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118251/ (Markdown: https://insights.sbomify.com/CVE-2026-118251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118251
- OSV: https://osv.dev/vulnerability/CVE-2026-118251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118251/
Summaries are generated and may contain mistakes; the official description above is the record.
