# CVE-2026-118253: Highcharts Dashboards: fullscreen labels are parsed as HTML


- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-58g7-7f52-h92c

## What is CVE-2026-118253?

CVE-2026-118253 is a high-severity vulnerability in @highcharts dashboards, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. From 1.0.0 until 4.2.3, Highcharts Dashboards edit mode parses fullscreen language labels as HTML rather than inserting them as text. An attacker who controls Dashboards language options can supply markup with event handlers, which execute in the hosting page origin when the fullscreen control is rendered. The label is reachable only when edit mode is enabled and viewFullscreen is present in the context-menu items. This issue is fixed in 4.2.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-118253?

2 open source packages ship an affected version, including @highcharts/dashboards.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@highcharts/dashboards` | npm | From 1.0.0 | 4.2.3 |
| `@highcharts/dashboards` | npm | From 1.0.0 | 4.2.3 |

## How do I fix CVE-2026-118253?

Upgrade @highcharts/dashboards to 4.2.3 or later.

## Is CVE-2026-118253 being exploited?

There is no known exploitation of CVE-2026-118253 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118253 and fix it if it is affected.

What it is: CVE-2026-118253 is a high-severity vulnerability in @highcharts dashboards, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118253 in the wild and no public exploit code.

Affected packages and fixed versions:
- @highcharts/dashboards (npm): affected from 1.0.0; fixed in 4.2.3
- @highcharts/dashboards (npm): affected from 1.0.0; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118253/ (Markdown: https://insights.sbomify.com/CVE-2026-118253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118253
- OSV: https://osv.dev/vulnerability/CVE-2026-118253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118253/
Summaries are generated and may contain mistakes; the official description above is the record.
