# CVE-2026-118254: Highcharts Grid: pagination language options are parsed as HTML


- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-r5wg-q8fc-p6w2

## What is CVE-2026-118254?

CVE-2026-118254 is a high-severity vulnerability in @highcharts grid-lite, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin when pagination controls render. Exploitation requires pagination to be enabled but does not require additional user interaction. This issue is fixed in 3.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-118254?

4 open source packages ship an affected version, including @highcharts/grid-lite and @highcharts/grid-pro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@highcharts/grid-lite` | npm | From 2.0.0 | 3.2.0 |
| `@highcharts/grid-lite` | npm | From 2.0.0 | 3.2.0 |
| `@highcharts/grid-pro` | npm | From 2.0.0 | 3.2.0 |
| `@highcharts/grid-pro` | npm | From 2.0.0 | 3.2.0 |

## How do I fix CVE-2026-118254?

Upgrade @highcharts/grid-lite to 3.2.0 or later.

## Is CVE-2026-118254 being exploited?

There is no known exploitation of CVE-2026-118254 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118254 and fix it if it is affected.

What it is: CVE-2026-118254 is a high-severity vulnerability in @highcharts grid-lite, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118254 in the wild and no public exploit code.

Affected packages and fixed versions:
- @highcharts/grid-lite (npm): affected from 2.0.0; fixed in 3.2.0
- @highcharts/grid-lite (npm): affected from 2.0.0; fixed in 3.2.0
- @highcharts/grid-pro (npm): affected from 2.0.0; fixed in 3.2.0
- @highcharts/grid-pro (npm): affected from 2.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118254/ (Markdown: https://insights.sbomify.com/CVE-2026-118254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118254
- OSV: https://osv.dev/vulnerability/CVE-2026-118254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118254/
Summaries are generated and may contain mistakes; the official description above is the record.
