# CVE-2026-118258: i18next-http-backend: Query-parameter injection through & and = in lng when loadPath/addPath puts {{lng}} in the query string


- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-3cmx-xjww-583x, UBUNTU-CVE-2026-118258

## What is CVE-2026-118258?

CVE-2026-118258 is a low-severity vulnerability in i18next-http-backend, published on 28 Oct 2026. 

### Official description

i18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers, and Deno. Prior to 4.0.4, interpolateUrl inserts unencoded language and namespace values into loadPath or addPath templates without rejecting ampersand (&), equals (=), or semicolon (;) query separators. When a template places lng or ns in the query string and an attacker controls that value, the attacker can add or override parameters on browser or server-side translation requests, potentially exposing other namespaces or tenants or changing backend behavior through the application's network position and credentials. This vulnerability is the result of an incomplete fix for CVE-2026-41691. This issue is fixed in version 4.0.4.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-118258?

2 open source packages ship an affected version, including i18next-http-backend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18next-http-backend` | npm | All versions | 4.0.4 |
| `i18next-http-backend` | npm | All versions | 4.0.4 |

## How do I fix CVE-2026-118258?

Upgrade i18next-http-backend to 4.0.4 or later.

## Is CVE-2026-118258 being exploited?

There is no known exploitation of CVE-2026-118258 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118258 and fix it if it is affected.

What it is: CVE-2026-118258 is a low-severity vulnerability in i18next-http-backend, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118258 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18next-http-backend (npm): affected all versions; fixed in 4.0.4
- i18next-http-backend (npm): affected all versions; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118258/ (Markdown: https://insights.sbomify.com/CVE-2026-118258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118258
- OSV: https://osv.dev/vulnerability/CVE-2026-118258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118258/
Summaries are generated and may contain mistakes; the official description above is the record.
