# CVE-2026-118261: Echo: Decompress permits unbounded gzip expansion in v4


- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-118261, ECHO-ebd5-7305-625a, GHSA-h7wr-284f-5qvc, ROOT-APP-GOBINARY-GHSA-h7wr-284f-5qvc, UBUNTU-CVE-2026-118261

## What is CVE-2026-118261?

CVE-2026-118261 is a high-severity vulnerability in labstack echo, published on 28 Oct 2026. 

### Official description

Echo is a Go web framework. From 4.0.0 until 4.16.1, Echo v4's opt-in Decompress middleware exposes a gzip-decoded request stream without limiting its expanded size. A small compressed request can expand into a very large body when a handler reads or binds it, consuming excessive memory or CPU and allowing repeated or concurrent requests to cause denial of service. The middleware is not enabled by default, and limiting only the compressed request size does not bound the decoded size. This issue is fixed in 4.16.1.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-118261?

2 open source packages ship an affected version, including github.com/labstack/echo/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/labstack/echo/v4` | Go | From 4.0.0 | 4.16.1 |
| `github.com/labstack/echo/v4` | Go | From 4.0.0 | 4.16.1 |

## How do I fix CVE-2026-118261?

Upgrade github.com/labstack/echo/v4 to 4.16.1 or later.

## Is CVE-2026-118261 being exploited?

There is no known exploitation of CVE-2026-118261 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118261 and fix it if it is affected.

What it is: CVE-2026-118261 is a high-severity vulnerability in labstack echo, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118261 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/labstack/echo/v4 (Go): affected from 4.0.0; fixed in 4.16.1
- github.com/labstack/echo/v4 (Go): affected from 4.0.0; fixed in 4.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118261/ (Markdown: https://insights.sbomify.com/CVE-2026-118261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118261
- OSV: https://osv.dev/vulnerability/CVE-2026-118261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118261/
Summaries are generated and may contain mistakes; the official description above is the record.
