# CVE-2026-118264: Echo: Rejected WebSocket upgrades can bypass Echo route-level access controls


- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-118264, ECHO-e1b6-15b1-4b64, GHSA-cxf3-9h37-7rr8, ROOT-APP-GOBINARY-GHSA-cxf3-9h37-7rr8, UBUNTU-CVE-2026-118264

## What is CVE-2026-118264?

CVE-2026-118264 is a critical vulnerability in labstack echo, published on 28 Oct 2026. 

### Official description

Echo is a Go web framework. From 4.0.0 until 4.16.1 and 5.4.1, Echo's Proxy middleware selects a raw tunnel from a client WebSocket upgrade request before verifying that the configured upstream accepted the upgrade. If the upstream rejects the upgrade with an ordinary keep-alive response, later HTTP requests on the connection are sent directly to that upstream without passing through Echo's router or route-specific middleware. This can bypass authentication or authorization enforced only by Echo routes, but requires an accessible proxy route, a cooperating rejected-upgrade response, and a target without independent upstream authorization. This issue is fixed in 4.16.1 and 5.4.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-118264?

4 open source packages ship an affected version, including github.com/labstack/echo/v4 and github.com/labstack/echo/v5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/labstack/echo/v4` | Go | From 4.0.0 | 4.16.1 |
| `github.com/labstack/echo/v4` | Go | From 4.0.0 | 4.16.1 |
| `github.com/labstack/echo/v5` | Go | From 5.0.0 | 5.4.1 |
| `github.com/labstack/echo/v5` | Go | From 5.0.0 | 5.4.1 |

## How do I fix CVE-2026-118264?

Upgrade github.com/labstack/echo/v4 to 4.16.1 or later.

## Is CVE-2026-118264 being exploited?

There is no known exploitation of CVE-2026-118264 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118264 and fix it if it is affected.

What it is: CVE-2026-118264 is a critical vulnerability in labstack echo, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118264 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/labstack/echo/v4 (Go): affected from 4.0.0; fixed in 4.16.1
- github.com/labstack/echo/v4 (Go): affected from 4.0.0; fixed in 4.16.1
- github.com/labstack/echo/v5 (Go): affected from 5.0.0; fixed in 5.4.1
- github.com/labstack/echo/v5 (Go): affected from 5.0.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118264/ (Markdown: https://insights.sbomify.com/CVE-2026-118264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118264
- OSV: https://osv.dev/vulnerability/CVE-2026-118264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118264/
Summaries are generated and may contain mistakes; the official description above is the record.
