# CVE-2026-118265: Echo: X-Real-IP extractor trusts the header value instead of the sending peer


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** ECHO-691a-c6cd-5f6b, GHSA-h53f-rm2w-w7rg, UBUNTU-CVE-2026-118265

## What is CVE-2026-118265?

CVE-2026-118265 is a medium-severity vulnerability in labstack echo, published on 28 Oct 2026. 

### Official description

Echo is a Go web framework. From 5.0.0 until 5.4.1, Echo v5's ExtractIPFromRealIPHeader validates whether the client-supplied X-Real-IP value belongs to a trusted range instead of validating the direct network peer. A client reaching Echo directly, or through a proxy that preserves the header, can supply a loopback or private address and have Context.RealIP return that spoofed identity. Applications using the extractor for IP allowlists, rate limiting, audit logs, or forwarding headers can consequently trust an attacker-controlled address; the default direct extractor and Echo v4 are unaffected. This issue is fixed in 5.4.1.

Weakness: CWE-348 (Use of Less Trusted Source)

## Which versions are affected by CVE-2026-118265?

2 open source packages ship an affected version, including github.com/labstack/echo/v5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/labstack/echo/v5` | Go | From 5.0.0 | 5.4.1 |
| `github.com/labstack/echo/v5` | Go | From 5.0.0 | 5.4.1 |

## How do I fix CVE-2026-118265?

Upgrade github.com/labstack/echo/v5 to 5.4.1 or later.

## Is CVE-2026-118265 being exploited?

There is no known exploitation of CVE-2026-118265 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118265 and fix it if it is affected.

What it is: CVE-2026-118265 is a medium-severity vulnerability in labstack echo, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118265 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/labstack/echo/v5 (Go): affected from 5.0.0; fixed in 5.4.1
- github.com/labstack/echo/v5 (Go): affected from 5.0.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118265/ (Markdown: https://insights.sbomify.com/CVE-2026-118265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118265
- OSV: https://osv.dev/vulnerability/CVE-2026-118265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118265/
Summaries are generated and may contain mistakes; the official description above is the record.
