CVE-2026-11827 Insufficiently Protected Credentials in GitLab
Authenticated maintainers can obtain other users' stored credentials due to improper authorization controls in GitLab.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-11827?
CVE-2026-11827 is a medium-severity vulnerability in Gitlab Gitlab, published on 8 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab EE affecting all versions from 9.5 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user with maintainer-role permissions to obtain another user's stored credentials due to improper authorization controls.
Weakness: CWE-522
Which versions are affected by CVE-2026-11827?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 9.5.0 | 18.11.7, 19.0.4, 19.1.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2026-11827?
Upgrade gitlab to a fixed version for your release line: 18.11.7, 19.0.4 or 19.1.2.
Is CVE-2026-11827 being exploited?
There is no known exploitation of CVE-2026-11827 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2026-11827, GHSA-mhr8-wccg-2q8g, MINI-23r8-rf94-mjgr, UBUNTU-CVE-2026-11827.