# CVE-2026-118653: Echo: Rate Limiter Bypass via Spoofed X-Forwarded-For Header in Default Configuration


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-118653, GHSA-246p-cpwv-v3jq, UBUNTU-CVE-2026-118653

## What is CVE-2026-118653?

CVE-2026-118653 is a medium-severity vulnerability in labstack echo, published on 28 Oct 2026. 

### Official description

Echo is a Go web framework. From 4.0.0 until 5.1.0, Context.RealIP falls back to client-supplied X-Forwarded-For or X-Real-IP values when Echo.IPExtractor is unset, and the default RateLimiter uses that result as its client identifier. A remote attacker can rotate arbitrary forwarded-address values to obtain new rate-limit buckets and bypass IP-based throttling used for controls such as brute-force or request-volume protection. This issue is fixed in Echo v5.1.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-118653?

4 open source packages ship an affected version, including github.com/labstack/echo/v4 and github.com/labstack/echo/v5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/labstack/echo/v4` | Go | From 4.0.0 to 4.16.2 | None |
| `github.com/labstack/echo/v4` | Go | From 4.0.0 to 4.16.2 | None |
| `github.com/labstack/echo/v5` | Go | All versions | 5.1.0 |
| `github.com/labstack/echo/v5` | Go | All versions | 5.1.0 |

## How do I fix CVE-2026-118653?

Upgrade to a fixed version.

## Is CVE-2026-118653 being exploited?

There is no known exploitation of CVE-2026-118653 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118653 and fix it if it is affected.

What it is: CVE-2026-118653 is a medium-severity vulnerability in labstack echo, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118653 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/labstack/echo/v4 (Go): affected from 4.0.0 up to 4.16.2; no fix listed
- github.com/labstack/echo/v4 (Go): affected from 4.0.0 up to 4.16.2; no fix listed
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.1.0
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118653/ (Markdown: https://insights.sbomify.com/CVE-2026-118653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118653
- OSV: https://osv.dev/vulnerability/CVE-2026-118653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118653/
Summaries are generated and may contain mistakes; the official description above is the record.
