# CVE-2026-118657: Echo: HTTPS Redirect and HSTS Bypass via Unconditional Trust of Forwarded Scheme Headers


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-118657, ECHO-931c-bced-8b2d, GHSA-2ffq-g2xg-c22p, UBUNTU-CVE-2026-118657

## What is CVE-2026-118657?

CVE-2026-118657 is a medium-severity vulnerability in labstack echo, published on 28 Oct 2026. 

### Official description

Echo is a Go web framework. Prior to 4.16.0 and 5.4.0, Context.Scheme unconditionally trusts forwarded scheme headers from any client. A client that reaches Echo directly over plaintext HTTP can claim an HTTPS scheme and bypass HTTPSRedirect because the request is treated as already secure. Separately, behind a TLS-terminating proxy that passes an attacker-controlled header, a claimed HTTP scheme can suppress the Strict-Transport-Security header even though the browser receives the response over HTTPS. The practical risk is reduced when a trusted proxy overwrites the headers and direct backend access is prevented, but the framework previously had no trusted-source configuration for this decision. This issue is fixed in 4.16.0 and 5.4.0.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-118657?

4 open source packages ship an affected version, including github.com/labstack/echo/v4 and github.com/labstack/echo/v5.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/labstack/echo/v4` | Go | All versions | 4.16.0 |
| `github.com/labstack/echo/v4` | Go | All versions | 4.16.0 |
| `github.com/labstack/echo/v5` | Go | All versions | 5.4.0 |
| `github.com/labstack/echo/v5` | Go | All versions | 5.4.0 |

## How do I fix CVE-2026-118657?

Upgrade github.com/labstack/echo/v4 to 4.16.0 or later.

## Is CVE-2026-118657 being exploited?

There is no known exploitation of CVE-2026-118657 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118657 and fix it if it is affected.

What it is: CVE-2026-118657 is a medium-severity vulnerability in labstack echo, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118657 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/labstack/echo/v4 (Go): affected all versions; fixed in 4.16.0
- github.com/labstack/echo/v4 (Go): affected all versions; fixed in 4.16.0
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.4.0
- github.com/labstack/echo/v5 (Go): affected all versions; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118657/ (Markdown: https://insights.sbomify.com/CVE-2026-118657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118657
- OSV: https://osv.dev/vulnerability/CVE-2026-118657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118657/
Summaries are generated and may contain mistakes; the official description above is the record.
