# CVE-2026-118659: @happy-dom/server-renderer: ServerRendererServer Target-Origin Bypass SSRF / Open Proxy


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-pmf4-3xr3-xjhg

## What is CVE-2026-118659?

CVE-2026-118659 is a high-severity vulnerability in capricorn86 happy-dom, published on 28 Oct 2026. 

### Official description

Happy DOM is a JavaScript implementation of a web browser without its graphical user interface. Prior to 21.0.2, the Happy DOM server-renderer package's ServerRendererServer accepts unauthenticated HTTP/2 requests and resolves attacker-controlled :path values against server.targetOrigin in #onIncomingRequest in packages/@happy-dom/server-renderer/src/ServerRendererServer.ts without confirming that the resolved origin remains trusted before calling fetch. A protocol-relative path can change the destination to an arbitrary HTTP or HTTPS endpoint reachable by the server, including local and internal services, and the proxy relays the fetched response headers and body to the requester. This issue is fixed in version 21.0.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-118659?


## How do I fix CVE-2026-118659?

No fix has been published for CVE-2026-118659 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-118659 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-118659 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118659 and fix it if it is affected.

What it is: CVE-2026-118659 is a high-severity vulnerability in capricorn86 happy-dom, published on 28 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-118659 exists.

Affected product: capricorn86 happy-dom. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118659/ (Markdown: https://insights.sbomify.com/CVE-2026-118659/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118659
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118659
- OSV: https://osv.dev/vulnerability/CVE-2026-118659

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118659/
Summaries are generated and may contain mistakes; the official description above is the record.
