# CVE-2026-118660: Happy DOM: SSRF via iframe and link stylesheet when parsing untrusted HTML


- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-c8p4-j97h-3vg8

## What is CVE-2026-118660?

CVE-2026-118660 is a high-severity vulnerability in capricorn86 happy-dom, published on 28 Oct 2026. 

### Official description

Happy DOM is a JavaScript implementation of a web browser without its graphical user interface. Prior to 21.0.0, Happy DOM loads iframe src URLs and link rel="stylesheet" href URLs by default while parsing untrusted HTML on the server because disableIframePageLoading and disableCSSFileLoading default to false. An attacker who controls parsed HTML can therefore cause server-side requests to arbitrary internal or cloud endpoints without an application opt-in and may expose confidential responses or credentials returned by those endpoints. This issue is fixed in version 21.0.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-118660?

2 open source packages ship an affected version, including happy-dom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `happy-dom` | npm | All versions | 21.0.0 |
| `happy-dom` | npm | All versions | 21.0.0 |

## How do I fix CVE-2026-118660?

Upgrade happy-dom to 21.0.0 or later.

## Is CVE-2026-118660 being exploited?

There is no known exploitation of CVE-2026-118660 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118660 and fix it if it is affected.

What it is: CVE-2026-118660 is a high-severity vulnerability in capricorn86 happy-dom, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118660 in the wild and no public exploit code.

Affected packages and fixed versions:
- happy-dom (npm): affected all versions; fixed in 21.0.0
- happy-dom (npm): affected all versions; fixed in 21.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118660/ (Markdown: https://insights.sbomify.com/CVE-2026-118660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118660
- OSV: https://osv.dev/vulnerability/CVE-2026-118660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118660/
Summaries are generated and may contain mistakes; the official description above is the record.
