# CVE-2026-118662: Vite: `server.fs.deny` bypassed with queries


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-8g5g-mxqh-grgj

## What is CVE-2026-118662?

CVE-2026-118662 is a medium-severity vulnerability in vitejs vite, published on 28 Oct 2026. 

### Official description

Vite is a frontend tooling framework for JavaScript. From 6.4.4 until 6.4.5, the Vite development server can evaluate server.fs.deny before stripping loader query parameters such as ?raw, ?import&raw, or ?import&url&inline. When the development server is exposed to the network and a sensitive file is inside server.fs.allow but matched by server.fs.deny, an unauthenticated attacker can append one of these queries and retrieve the denied file. This issue is fixed in version 6.4.5.

Weakness: CWE-284 (Improper Access Control), CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-118662?

2 open source packages ship an affected version, including vite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite` | npm | From 6.4.4 | 6.4.5 |
| `vite` | npm | From 6.4.4 | 6.4.5 |

## How do I fix CVE-2026-118662?

Upgrade vite to 6.4.5 or later.

## Is CVE-2026-118662 being exploited?

There is no known exploitation of CVE-2026-118662 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118662 and fix it if it is affected.

What it is: CVE-2026-118662 is a medium-severity vulnerability in vitejs vite, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118662 in the wild and no public exploit code.

Affected packages and fixed versions:
- vite (npm): affected from 6.4.4; fixed in 6.4.5
- vite (npm): affected from 6.4.4; fixed in 6.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118662/ (Markdown: https://insights.sbomify.com/CVE-2026-118662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118662
- OSV: https://osv.dev/vulnerability/CVE-2026-118662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118662/
Summaries are generated and may contain mistakes; the official description above is the record.
