# CVE-2026-118663: @hono/node-server: `serveStatic` decodes the request path a second time, leading to bypass of middleware on static paths


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-rmxm-3fg6-px4f, MINI-48rv-78f7-7x9x

## What is CVE-2026-118663?

CVE-2026-118663 is a medium-severity vulnerability in honojs node-server, published on 28 Oct 2026. 

### Official description

@hono/node-server allows running the Hono application on Node.js. From 1.19.10 until 2.1.3, serveStatic decodes a request path a second time after Hono has already decoded it for routing, so a malformed percent-encoded sequence can make route middleware evaluate an encoded path while static file resolution uses a different directory. An unauthenticated attacker can bypass middleware mounted on a protected static prefix and read a file inside the configured static root, although the flaw does not permit traversal outside that root. This issue is fixed in version 2.1.3.

Weakness: CWE-174 (Double Decoding of the Same Data)

## Which versions are affected by CVE-2026-118663?

2 open source packages ship an affected version, including @hono/node-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hono/node-server` | npm | From 1.19.10 | 2.1.3 |
| `@hono/node-server` | npm | From 1.19.10 | 2.1.3 |

## How do I fix CVE-2026-118663?

Upgrade @hono/node-server to 2.1.3 or later.

## Is CVE-2026-118663 being exploited?

There is no known exploitation of CVE-2026-118663 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118663 and fix it if it is affected.

What it is: CVE-2026-118663 is a medium-severity vulnerability in honojs node-server, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118663 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hono/node-server (npm): affected from 1.19.10; fixed in 2.1.3
- @hono/node-server (npm): affected from 1.19.10; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118663/ (Markdown: https://insights.sbomify.com/CVE-2026-118663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118663
- OSV: https://osv.dev/vulnerability/CVE-2026-118663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118663/
Summaries are generated and may contain mistakes; the official description above is the record.
