# CVE-2026-118664: decode-uri-component: Denial of service via quadratic replacement of percent-encoded runs


- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-qr28-fpjm-wq7f

## What is CVE-2026-118664?

CVE-2026-118664 is a high-severity vulnerability in SamVerschueren decode-uri-component, published on 28 Oct 2026. 

### Official description

decode-uri-component provides a more robust alternative to decodeURIComponent. Prior to 0.5.1, decodeUriComponent in index.js falls back to customDecodeURIComponent after native decoding throws, and the fallback collects every distinct percent-encoded run before performing a full-string regular-expression replacement for each entry. Malformed input containing many distinct runs can therefore make both the number of replacements and the scanned input length grow together, causing quadratic CPU consumption and blocking the Node.js event loop; request-body inputs can reach the demonstrated size, while ordinary URL header limits reduce the practical delay. This issue is fixed in version 0.5.1.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-118664?

2 open source packages ship an affected version, including decode-uri-component.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decode-uri-component` | npm | All versions | 0.5.1 |
| `decode-uri-component` | npm | All versions | 0.5.1 |

## How do I fix CVE-2026-118664?

Upgrade decode-uri-component to 0.5.1 or later.

## Is CVE-2026-118664 being exploited?

There is no known exploitation of CVE-2026-118664 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118664 and fix it if it is affected.

What it is: CVE-2026-118664 is a high-severity vulnerability in SamVerschueren decode-uri-component, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118664 in the wild and no public exploit code.

Affected packages and fixed versions:
- decode-uri-component (npm): affected all versions; fixed in 0.5.1
- decode-uri-component (npm): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118664/ (Markdown: https://insights.sbomify.com/CVE-2026-118664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118664
- OSV: https://osv.dev/vulnerability/CVE-2026-118664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118664/
Summaries are generated and may contain mistakes; the official description above is the record.
