# CVE-2026-118666: GraphQL Tools: Shared legacy executor routes one subscription's results to a different caller


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-mp66-8ww2-pcwm

## What is CVE-2026-118666?

CVE-2026-118666 is a medium-severity vulnerability in @graphql-tools executor-legacy-ws, published on 28 Oct 2026. 

### Official description

GraphQL Tools provides utilities for building, stitching, and mocking GraphQL schemas. Prior to version 1.1.36 of the GraphQL Tools legacy WebSocket executor package, buildWSLegacyExecutor in packages/executors/legacy-ws/src/index.ts reuses one WebSocket and replaces its single websocket.onmessage handler whenever a new overlapping subscription starts. The handler delivers LEGACY_WS.DATA frames to the newest observer without comparing data.id with the subscription operation id, so a caller using the same executor can receive another user's authorized subscription payload while the earlier caller's stream is starved. This issue is fixed in version 1.1.36 of the GraphQL Tools legacy WebSocket executor package.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-118666?

2 open source packages ship an affected version, including @graphql-tools/executor-legacy-ws.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@graphql-tools/executor-legacy-ws` | npm | All versions | 1.1.36 |
| `@graphql-tools/executor-legacy-ws` | npm | All versions | 1.1.36 |

## How do I fix CVE-2026-118666?

Upgrade @graphql-tools/executor-legacy-ws to 1.1.36 or later.

## Is CVE-2026-118666 being exploited?

There is no known exploitation of CVE-2026-118666 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118666 and fix it if it is affected.

What it is: CVE-2026-118666 is a medium-severity vulnerability in @graphql-tools executor-legacy-ws, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118666 in the wild and no public exploit code.

Affected packages and fixed versions:
- @graphql-tools/executor-legacy-ws (npm): affected all versions; fixed in 1.1.36
- @graphql-tools/executor-legacy-ws (npm): affected all versions; fixed in 1.1.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118666/ (Markdown: https://insights.sbomify.com/CVE-2026-118666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118666
- OSV: https://osv.dev/vulnerability/CVE-2026-118666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118666/
Summaries are generated and may contain mistakes; the official description above is the record.
