# CVE-2026-118667: LangGraph: Unencoded identifiers in LangGraph SDK v3 streaming can redirect authenticated GET requests


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-3fx2-cqw9-xr3c

## What is CVE-2026-118667?

CVE-2026-118667 is a medium-severity vulnerability in langchain-ai langgraph, published on 28 Oct 2026. 

### Official description

LangGraph Python SDK is used to connect to running LangGraph API servers, manage assistants, threads and stream runs from Python applications. From langgraph-sdk 0.4.0 until 0.4.6, and from langgraph 1.2.3 until 1.2.14 when RemoteGraph v3 streaming uses an affected langgraph-sdk version, the synchronous and asynchronous v3 stream get_tree and _fetch_state helpers interpolate caller-controlled assistant_id and thread_id values into authenticated GET request paths without using _quote_path_param. Relative path segments can therefore be normalized into another readable path on the configured server while retaining authentication headers. This issue is fixed in langgraph-sdk 0.4.6 and langgraph 1.2.14.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-118667?

4 open source packages ship an affected version, including langgraph and langgraph-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph` | PyPI | From 1.2.3 | 1.2.14 |
| `langgraph` | PyPI | From 1.2.3 | 1.2.14 |
| `langgraph-sdk` | PyPI | From 0.4.0 | 0.4.6 |
| `langgraph-sdk` | PyPI | From 0.4.0 | 0.4.6 |

## How do I fix CVE-2026-118667?

Upgrade langgraph to 1.2.14 or later.

## Is CVE-2026-118667 being exploited?

There is no known exploitation of CVE-2026-118667 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118667 and fix it if it is affected.

What it is: CVE-2026-118667 is a medium-severity vulnerability in langchain-ai langgraph, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118667 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph (PyPI): affected from 1.2.3; fixed in 1.2.14
- langgraph (PyPI): affected from 1.2.3; fixed in 1.2.14
- langgraph-sdk (PyPI): affected from 0.4.0; fixed in 0.4.6
- langgraph-sdk (PyPI): affected from 0.4.0; fixed in 0.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118667/ (Markdown: https://insights.sbomify.com/CVE-2026-118667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118667
- OSV: https://osv.dev/vulnerability/CVE-2026-118667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118667/
Summaries are generated and may contain mistakes; the official description above is the record.
