CVE-2026-118668 LangGraph JavaScript custom authentication may permit cross-user Store access

High 8.6 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-118668?

CVE-2026-118668 is a high-severity vulnerability in langchain-ai langgraph-api, published on 28 Oct 2026.

Official description

langgraph-api implements the LangGraph API for rapid development and testing. From 0.1.2 until 0.15.0, JavaScript or TypeScript custom authentication Store authorization handlers can return a rewritten namespace that is not carried across the runtime boundary and applied before the Store operation. An authenticated user can therefore access another user's Store namespace when a deployment relies on namespace rewriting for isolation, allowing unauthorized reads, overwrites, searches, or deletions. Python custom authentication and handlers that reject unauthorized namespaces instead of rewriting them are not affected. This issue is fixed in version 0.15.0.

Weakness: CWE-863, CWE-639

Which versions are affected by CVE-2026-118668?

2 open source packages ship an affected version, including langgraph-api.

PackageAffectedFixed in
langgraph-api PyPIFrom 0.1.20.15.0
langgraph-api PyPIFrom 0.1.20.15.0

How do I fix CVE-2026-118668?

Upgrade langgraph-api to 0.15.0 or later.

Is CVE-2026-118668 being exploited?

There is no known exploitation of CVE-2026-118668 in the wild and no public exploit code.

Sources

Also known as GHSA-4hm6-w6qq-w73v.

Is CVE-2026-118668 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free