# CVE-2026-118668: LangGraph JavaScript custom authentication may permit cross-user Store access


- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-4hm6-w6qq-w73v

## What is CVE-2026-118668?

CVE-2026-118668 is a high-severity vulnerability in langchain-ai langgraph-api, published on 28 Oct 2026. 

### Official description

langgraph-api implements the LangGraph API for rapid development and testing. From 0.1.2 until 0.15.0, JavaScript or TypeScript custom authentication Store authorization handlers can return a rewritten namespace that is not carried across the runtime boundary and applied before the Store operation. An authenticated user can therefore access another user's Store namespace when a deployment relies on namespace rewriting for isolation, allowing unauthorized reads, overwrites, searches, or deletions. Python custom authentication and handlers that reject unauthorized namespaces instead of rewriting them are not affected. This issue is fixed in version 0.15.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-118668?

2 open source packages ship an affected version, including langgraph-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-api` | PyPI | From 0.1.2 | 0.15.0 |
| `langgraph-api` | PyPI | From 0.1.2 | 0.15.0 |

## How do I fix CVE-2026-118668?

Upgrade langgraph-api to 0.15.0 or later.

## Is CVE-2026-118668 being exploited?

There is no known exploitation of CVE-2026-118668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118668 and fix it if it is affected.

What it is: CVE-2026-118668 is a high-severity vulnerability in langchain-ai langgraph-api, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118668 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-api (PyPI): affected from 0.1.2; fixed in 0.15.0
- langgraph-api (PyPI): affected from 0.1.2; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118668/ (Markdown: https://insights.sbomify.com/CVE-2026-118668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118668
- OSV: https://osv.dev/vulnerability/CVE-2026-118668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118668/
Summaries are generated and may contain mistakes; the official description above is the record.
