# CVE-2026-118669: OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client


- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-118669, GHSA-7984-qgvg-3j9c

## What is CVE-2026-118669?

CVE-2026-118669 is a high-severity vulnerability in oauthlib, published on 28 Oct 2026. 

### Official description

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. Prior to 4.0.0, the client_credentials and Resource Owner Password Credentials token grant handlers can authenticate request.client as one confidential client while retaining an attacker-supplied request.client_id for validate_grant_type and validate_scopes. A lower-privilege authenticated client can therefore cause grant and scope authorization to use another client's identity when an application validator relies on the documented client_id argument, potentially issuing tokens with unauthorized grants or scopes. Validators that authorize exclusively from request.client may not be affected. This issue is fixed in version 4.0.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-118669?


## How do I fix CVE-2026-118669?

No fix has been published for CVE-2026-118669 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-118669 being exploited?

There is no known exploitation of CVE-2026-118669 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118669 and fix it if it is affected.

What it is: CVE-2026-118669 is a high-severity vulnerability in oauthlib, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118669 in the wild and no public exploit code.

Affected product: oauthlib. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118669/ (Markdown: https://insights.sbomify.com/CVE-2026-118669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118669
- OSV: https://osv.dev/vulnerability/CVE-2026-118669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118669/
Summaries are generated and may contain mistakes; the official description above is the record.
