# CVE-2026-118764: minimatch: potential denial of service via globparts amplification


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-118764, GHSA-g3hv-75wg-m249

## What is CVE-2026-118764?

CVE-2026-118764 is a high-severity vulnerability in isaacs minimatch, published on 29 Oct 2026. 

### Official description

minimatch is a minimal matching utility for converting glob expressions into JavaScript RegExp objects. Prior to 11.0.1, src/index.ts implements firstPhasePreProcess() so that, at optimizationLevel 2 or higher, it repeatedly expands attacker-controlled **/.. pattern segments inside a fixpoint loop, allowing generated globParts entries to be processed and expanded again. secondPhasePreProcess() then compares the expanded entries pairwise, so a short malicious glob can cause excessive CPU and memory consumption during pattern compilation. This issue is fixed in version 11.0.1.

Weakness: CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2026-118764?


## How do I fix CVE-2026-118764?

No fix has been published for CVE-2026-118764 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-118764 being exploited?

There is no known exploitation of CVE-2026-118764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118764 and fix it if it is affected.

What it is: CVE-2026-118764 is a high-severity vulnerability in isaacs minimatch, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-118764 in the wild and no public exploit code.

Affected product: isaacs minimatch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118764/ (Markdown: https://insights.sbomify.com/CVE-2026-118764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118764
- OSV: https://osv.dev/vulnerability/CVE-2026-118764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118764/
Summaries are generated and may contain mistakes; the official description above is the record.
