# CVE-2026-118779: Forge: Regular expression denial of service in PEM decoding (pem.decode)


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-118779?

CVE-2026-118779 is a high-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 

### Official description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, the affected implementation used pem.decode(), lib/pem.js, missing END line to process the relevant input or security decision. node-forge used polynomial-time regular expressions in pem.decode(), including when searching for a matching END line and parsing encapsulated headers. An unauthenticated attacker able to supply PEM input to any high-level parser could consume excessive CPU with a long malformed message and cause denial of service. This issue is fixed in version 1.4.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-118779?


## How do I fix CVE-2026-118779?

No fix has been published for CVE-2026-118779 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-118779 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-118779 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-118779 and fix it if it is affected.

What it is: CVE-2026-118779 is a high-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-118779 exists.

Affected product: digitalbazaar forge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-118779/ (Markdown: https://insights.sbomify.com/CVE-2026-118779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-118779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-118779
- OSV: https://osv.dev/vulnerability/CVE-2026-118779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-118779/
Summaries are generated and may contain mistakes; the official description above is the record.
