# CVE-2026-119130: Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 HTTP Request Target Smuggling


- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-119130, GHSA-5qpp-g3j2-8frx, GHSA-pr9x-c379-2x4g, RUSTSEC-2026-0350

## What is CVE-2026-119130?

CVE-2026-119130 is a low-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 

### Official description

Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 does not verify that set-path-with-query values in wasmtime-wasi-http are paths, so absolute-form URLs are written verbatim as the HTTP/1.1 request target while the connection uses the allowed authority. A malicious guest can supply an absolute URL that a forward proxy or gateway at that authority honors, reaching hosts disallowed by embedder filtering policies.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-119130?

1 open source package ship an affected version, including wasmtime-wasi-http.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime-wasi-http` | crates.io | From 0.0.0-0 | 36.0.18, 48.0.6, 49.0.3 |

## How do I fix CVE-2026-119130?

Upgrade wasmtime-wasi-http to a fixed version for your release line: 36.0.18, 48.0.6 or 49.0.3.

## Is CVE-2026-119130 being exploited?

There is no known exploitation of CVE-2026-119130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119130 and fix it if it is affected.

What it is: CVE-2026-119130 is a low-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119130 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime-wasi-http (crates.io): affected from 0.0.0-0; fixed in 36.0.18, 48.0.6, 49.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119130/ (Markdown: https://insights.sbomify.com/CVE-2026-119130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119130
- OSV: https://osv.dev/vulnerability/CVE-2026-119130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119130/
Summaries are generated and may contain mistakes; the official description above is the record.
