# CVE-2026-119132: Wasmtime 49.0.0 before 49.0.3 Host Panic via Overlapping String Transcode in Fused Adapter


- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-54p9-vhhq-8f7q, GHSA-hv43-9665-59p4, RUSTSEC-2026-0360

## What is CVE-2026-119132?

CVE-2026-119132 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 

### Official description

Wasmtime from 49.0.0 before 49.0.3 contains a denial-of-service vulnerability that allows a WebAssembly guest to trigger a host panic by transcoding overlapping strings in fused adapters. Attackers can make a same-instance component-to-component call transferring a string whose source and destination alias each other, crashing the host instead of raising a trap.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-119132?

1 open source package ship an affected version, including wasmtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | From 49.0.0 | 49.0.3 |

## How do I fix CVE-2026-119132?

Upgrade wasmtime to 49.0.3 or later.

## Is CVE-2026-119132 being exploited?

There is no known exploitation of CVE-2026-119132 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119132 and fix it if it is affected.

What it is: CVE-2026-119132 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119132 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected from 49.0.0; fixed in 49.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119132/ (Markdown: https://insights.sbomify.com/CVE-2026-119132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119132
- OSV: https://osv.dev/vulnerability/CVE-2026-119132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119132/
Summaries are generated and may contain mistakes; the official description above is the record.
