# CVE-2026-119134: Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 caps component-model resource handle tables only per component insta


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-119134, GHSA-59gg-q3p6-vwvr, GHSA-q554-3cjc-rx7p, RUSTSEC-2026-0363

## What is CVE-2026-119134?

CVE-2026-119134 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 

### Official description

Wasmtime before 36.0.18, 37.0.0 before 48.0.6, and 49.0.0 before 49.0.3 caps component-model resource handle tables only per component instance and does not charge handle allocations to any ResourceLimiter or StoreLimits. A malicious guest can repeatedly call resource.new and instantiate sub-components to exceed the per-instance cap many times over, causing unbounded host memory growth.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-119134?

1 open source package ship an affected version, including wasmtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | From 0.0.0-0 | 36.0.18, 48.0.6, 49.0.3 |

## How do I fix CVE-2026-119134?

Upgrade wasmtime to a fixed version for your release line: 36.0.18, 48.0.6 or 49.0.3.

## Is CVE-2026-119134 being exploited?

There is no known exploitation of CVE-2026-119134 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119134 and fix it if it is affected.

What it is: CVE-2026-119134 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119134 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected from 0.0.0-0; fixed in 36.0.18, 48.0.6, 49.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119134/ (Markdown: https://insights.sbomify.com/CVE-2026-119134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119134
- OSV: https://osv.dev/vulnerability/CVE-2026-119134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119134/
Summaries are generated and may contain mistakes; the official description above is the record.
