CVE-2026-119137 Wasmtime 42.0.0 before 48.0.6 and 49.0.0 before 49.0.3 Stack Overflow via Type Registry

Medium 6.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-119137?

CVE-2026-119137 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026.

Official description

Wasmtime 42.0.0 before 48.0.6 and 49.0.0 before 49.0.3 contains a stack overflow vulnerability that allows guests to crash the host through recursive type drops. Guests can define a long chain of recursive types so that removing the top-level type triggers unbounded recursive drops, exhausting the host stack.

Weakness: CWE-674

Which versions are affected by CVE-2026-119137?

1 open source package ship an affected version, including wasmtime.

PackageAffectedFixed in
wasmtime crates.ioFrom 42.0.048.0.6, 49.0.3

How do I fix CVE-2026-119137?

Upgrade wasmtime to a fixed version for your release line: 48.0.6 or 49.0.3.

Is CVE-2026-119137 being exploited?

There is no known exploitation of CVE-2026-119137 in the wild and no public exploit code.

Sources

Also known as GHSA-42v6-vp8p-fcjx, GHSA-wjc8-633q-pwxr, RUSTSEC-2026-0359.

Is CVE-2026-119137 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free