CVE-2026-119138 Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 Panic After Trap

Medium 5.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-119138?

CVE-2026-119138 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026.

Official description

Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 contains a denial of service vulnerability that allows pending calls to trigger an assertion failure after a trap poisons the Store. Attackers supplying misbehaving guest code can cause a trap and let earlier calls proceed, crashing embedders that continue using the inconsistent Store.

Weakness: CWE-617

Which versions are affected by CVE-2026-119138?

1 open source package ship an affected version, including wasmtime.

PackageAffectedFixed in
wasmtime crates.ioFrom 46.0.048.0.6, 49.0.3

How do I fix CVE-2026-119138?

Upgrade wasmtime to a fixed version for your release line: 48.0.6 or 49.0.3.

Is CVE-2026-119138 being exploited?

There is no known exploitation of CVE-2026-119138 in the wild and no public exploit code.

Sources

Also known as GHSA-5vwq-v85g-fcqv, GHSA-hmwq-g22x-qjw5, RUSTSEC-2026-0361.

Is CVE-2026-119138 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free