# CVE-2026-119139: Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 Host Panic via Func::call


- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-6862-c5q5-q6rc, GHSA-m6w2-jwq2-cv2c, RUSTSEC-2026-0353

## What is CVE-2026-119139?

CVE-2026-119139 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 

### Official description

Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 contains a leftover assertion in component::Func::call that rejects guest exports using the async ABI option. An attacker who supplies a component with an async-lifted export can crash the host process when an embedder invokes that export through Func::call.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-119139?

1 open source package ship an affected version, including wasmtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | From 46.0.0 | 48.0.6, 49.0.3 |

## How do I fix CVE-2026-119139?

Upgrade wasmtime to a fixed version for your release line: 48.0.6 or 49.0.3.

## Is CVE-2026-119139 being exploited?

There is no known exploitation of CVE-2026-119139 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119139 and fix it if it is affected.

What it is: CVE-2026-119139 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119139 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected from 46.0.0; fixed in 48.0.6, 49.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119139/ (Markdown: https://insights.sbomify.com/CVE-2026-119139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119139
- OSV: https://osv.dev/vulnerability/CVE-2026-119139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119139/
Summaries are generated and may contain mistakes; the official description above is the record.
