CVE-2026-119140 Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 Host Panic via thread.yield
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-119140?
CVE-2026-119140 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 29 Oct 2026.
Official description
Wasmtime 46.0.0 before 48.0.6 and 49.0.0 before 49.0.3 contains a denial of service vulnerability that allows malicious components to panic the host via thread.yield in start functions. Attackers can supply a component whose start function calls an async-lowered import then thread.yield, causing an undisposed fiber drop that crashes embedders.
Weakness: CWE-372
Which versions are affected by CVE-2026-119140?
1 open source package ship an affected version, including wasmtime.
| Package | Affected | Fixed in |
|---|---|---|
wasmtime crates.io | From 46.0.0 | 48.0.6, 49.0.3 |
How do I fix CVE-2026-119140?
Upgrade wasmtime to a fixed version for your release line: 48.0.6 or 49.0.3.
Is CVE-2026-119140 being exploited?
There is no known exploitation of CVE-2026-119140 in the wild and no public exploit code.
Sources
Also known as GHSA-5hhx-4wrr-3j9g, GHSA-wf7v-f5qh-m5xv, RUSTSEC-2026-0358.