# CVE-2026-119186: Forge: AES-GCM authentication bypass via unvalidated tagLength option


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119186?

CVE-2026-119186 is a medium-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 

### Official description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, node-forge did not validate the AES-GCM tagLength option passed to start() during decryption through forge.cipher.createDecipher(). When an application derived tagLength from received data or used an unset or zero-like configuration value, a value that converted to zero together with an empty or missing authentication tag caused the calculated and supplied tags to compare as empty, so decipher.finish() accepted unauthenticated ciphertext. Applications that omit tagLength to use the 128-bit default or pass a fixed valid tag length are unaffected. This issue is fixed in version 1.4.1.

Weakness: CWE-354 (Improper Validation of Integrity Check Value), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-119186?


## How do I fix CVE-2026-119186?

No fix has been published for CVE-2026-119186 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119186 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-119186 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119186 and fix it if it is affected.

What it is: CVE-2026-119186 is a medium-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-119186 exists.

Affected product: digitalbazaar forge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119186/ (Markdown: https://insights.sbomify.com/CVE-2026-119186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119186
- OSV: https://osv.dev/vulnerability/CVE-2026-119186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119186/
Summaries are generated and may contain mistakes; the official description above is the record.
