# CVE-2026-119190: Forge: X.509 basicConstraints bypass in verifyCertificateChain() via deprecated extension OIDs 2.5.29.10 and 2.5.29.13


- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119190?

CVE-2026-119190 is a high-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 

### Official description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, node-forge parsed deprecated extension OIDs 2.5.29.10 and 2.5.29.13 as basicConstraints, and pki.verifyCertificateChain() used the first extension with that name. Exploitation requires a CA trusted by the application to issue a certificate carrying an attacker-supplied deprecated-OID extension, commonly because the CA copies extensions from a certificate signing request. By placing a permissive deprecated extension before the genuine 2.5.29.19 basicConstraints extension, the certificate holder could have the certificate accepted as a CA and issue certificates for arbitrary names, enabling server or client impersonation. If the issuing CA adds a keyUsage extension without keyCertSign, node-forge rejects the chain. This issue is fixed in version 1.4.1.

Weakness: CWE-436 (Interpretation Conflict), CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-119190?


## How do I fix CVE-2026-119190?

No fix has been published for CVE-2026-119190 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119190 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-119190 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119190 and fix it if it is affected.

What it is: CVE-2026-119190 is a high-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-119190 exists.

Affected product: digitalbazaar forge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119190/ (Markdown: https://insights.sbomify.com/CVE-2026-119190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119190
- OSV: https://osv.dev/vulnerability/CVE-2026-119190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119190/
Summaries are generated and may contain mistakes; the official description above is the record.
