# CVE-2026-119191: Forge: ASN.1 resource exhaustion via BIT STRING decoding in asn1.fromDer


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119191?

CVE-2026-119191 is a high-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 

### Official description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, the affected implementation used asn1.fromDer(), BIT STRING decoding, maxDepth to process the relevant input or security decision. node-forge decoded ASN.1 stored inside BIT STRING values without consistently applying the configured maxDepth limit and recursively retained copies at each nesting level. Crafted DER containing nested BIT STRINGs could cause excessive recursion, CPU use, and quadratic memory consumption during asn1.fromDer(). This issue is fixed in version 1.4.1.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-119191?


## How do I fix CVE-2026-119191?

No fix has been published for CVE-2026-119191 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119191 being exploited?

There is no known exploitation of CVE-2026-119191 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119191 and fix it if it is affected.

What it is: CVE-2026-119191 is a high-severity vulnerability in digitalbazaar forge, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119191 in the wild and no public exploit code.

Affected product: digitalbazaar forge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119191/ (Markdown: https://insights.sbomify.com/CVE-2026-119191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119191
- OSV: https://osv.dev/vulnerability/CVE-2026-119191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119191/
Summaries are generated and may contain mistakes; the official description above is the record.
