# CVE-2026-119193: PHPUnit vulnerable to code execution by other local users via shared temporary directory in PHPT code coverage handling


- **Severity:** Medium 5.4 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119193?

CVE-2026-119193 is a medium-severity vulnerability in sebastianbergmann phpunit, published on 29 Oct 2026. 

### Official description

PHPUnit is a testing framework for PHP. From 13.4.0 until 13.4.4, the TestCase::coverageFilesDirectory() logic in src/Runner/Phpt/TestCase.php creates temporary files for PHPT code coverage in a predictable phpunit-phpt directory under sys_get_temp_dir() and reuses that directory without verifying its ownership or permissions. On multi-user systems with a shared temporary path, a local attacker who creates the directory before the developer runs PHPT tests with code coverage can replace the generated job file before the child process executes it with require, allowing arbitrary code execution with the developer's privileges while the test and coverage report appear successful. PHPUnit 12.5 and earlier, default macOS and Windows configurations with per-user temporary directories, and single-user environments where another user cannot create files in the temporary path are not affected. This issue is fixed in 13.4.4.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions)

## Which versions are affected by CVE-2026-119193?


## How do I fix CVE-2026-119193?

No fix has been published for CVE-2026-119193 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119193 being exploited?

There is no known exploitation of CVE-2026-119193 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119193 and fix it if it is affected.

What it is: CVE-2026-119193 is a medium-severity vulnerability in sebastianbergmann phpunit, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119193 in the wild and no public exploit code.

Affected product: sebastianbergmann phpunit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119193/ (Markdown: https://insights.sbomify.com/CVE-2026-119193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119193
- OSV: https://osv.dev/vulnerability/CVE-2026-119193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119193/
Summaries are generated and may contain mistakes; the official description above is the record.
