# CVE-2026-119195: pyasn1: Quadratic-time denial of service in constructed string and indefinite-length ANY decoding


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119195?

CVE-2026-119195 is a high-severity vulnerability in pyasn1, published on 29 Oct 2026. 

### Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.5, constructed string and indefinite-length ANY decoding repeatedly concatenates each fragment onto a growing bytes value. Attacker-controlled BER or CER data can use many constructed OCTET STRING or character-string fragments. DER rejects constructed OCTET STRING without a schema, but accepts its definite-length form when asn1Spec selects univ.OctetString; it also accepts constructed character strings such as UTF8String without a schema, even though those encodings are not valid DER. The separate indefinite-length ANY path is reachable in BER and CER when asn1Spec selects univ.Any; DER rejects indefinite lengths. OctetStringPayloadDecoder uses growing header concatenation and AnyPayloadDecoder.indefLenValueDecoder uses growing chunk concatenation, repeatedly copying an increasing prefix and causing quadratic work. A sufficiently fragmented value can occupy decoding workers and cause CPU exhaustion without confidentiality or integrity impact. This issue is fixed in version 0.6.5.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-119195?


## How do I fix CVE-2026-119195?

No fix has been published for CVE-2026-119195 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119195 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-119195 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119195 and fix it if it is affected.

What it is: CVE-2026-119195 is a high-severity vulnerability in pyasn1, published on 29 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-119195 exists.

Affected product: pyasn1. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119195/ (Markdown: https://insights.sbomify.com/CVE-2026-119195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119195
- OSV: https://osv.dev/vulnerability/CVE-2026-119195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119195/
Summaries are generated and may contain mistakes; the official description above is the record.
