# CVE-2026-119197: pyasn1: Quadratic-complexity denial of service in binary REAL decoding


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119197?

CVE-2026-119197 is a high-severity vulnerability in pyasn1, published on 29 Oct 2026. 

### Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.5, binary REAL decoding builds a large mantissa one octet at a time by shifting a growing integer and slicing the remaining byte string. Attacker-controlled ASN.1 includes a binary-encoded REAL with a large mantissa and reaches BER, CER, or DER decode(), with or without a schema containing REAL. RealPayloadDecoder.valueDecoder repeatedly performs a left shift, OR, and suffix copy for every mantissa octet, making decode time quadratic in mantissa length. A comparatively small REAL value can hold a decoding worker on one CPU core for seconds or longer and cause availability loss. This issue is fixed in version 0.6.5.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-119197?


## How do I fix CVE-2026-119197?

No fix has been published for CVE-2026-119197 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119197 being exploited?

There is no known exploitation of CVE-2026-119197 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119197 and fix it if it is affected.

What it is: CVE-2026-119197 is a high-severity vulnerability in pyasn1, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119197 in the wild and no public exploit code.

Affected product: pyasn1. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119197/ (Markdown: https://insights.sbomify.com/CVE-2026-119197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119197
- OSV: https://osv.dev/vulnerability/CVE-2026-119197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119197/
Summaries are generated and may contain mistakes; the official description above is the record.
