# CVE-2026-119200: Nuxt: Dot segments in the request path bypass `server/middleware` path checks and server route rules on page routes


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119200?

CVE-2026-119200 is a medium-severity vulnerability in @nuxt nitro-server, published on 29 Oct 2026. 

### Official description

Nuxt is an open-source web development framework for Vue.js. From 4.6.0 until 4.6.3, Nuxt resolves literal or percent-encoded dot segments before rendering a page while Nitro routing, server/middleware checks, and server route rules evaluate the unresolved path. A request such as /%2e/admin can therefore render app/pages/admin.vue and its server-rendered data while checks keyed to /admin, redirects, or per-route security headers do not apply. API handlers, appMiddleware, Nuxt 3, and Nuxt 4.0.0 through 4.5.x are not affected, and exploitation requires a client that sends dot segments without browser normalization. This issue is fixed in version 4.6.3.

Weakness: CWE-863 (Incorrect Authorization), CWE-436 (Interpretation Conflict), CWE-41 (Improper Resolution of Path Equivalence)

## Which versions are affected by CVE-2026-119200?


## How do I fix CVE-2026-119200?

No fix has been published for CVE-2026-119200 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119200 being exploited?

There is no known exploitation of CVE-2026-119200 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119200 and fix it if it is affected.

What it is: CVE-2026-119200 is a medium-severity vulnerability in @nuxt nitro-server, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119200 in the wild and no public exploit code.

Affected product: @nuxt nitro-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119200/ (Markdown: https://insights.sbomify.com/CVE-2026-119200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119200
- OSV: https://osv.dev/vulnerability/CVE-2026-119200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119200/
Summaries are generated and may contain mistakes; the official description above is the record.
