# CVE-2026-119283: joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards.


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119283?

CVE-2026-119283 is a high-severity vulnerability in authlib joserfc, published on 29 Oct 2026. 

### Official description

joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. Prior to 1.7.5, joserfc.jwe.decrypt_json() accepts a JWE General JSON Serialization recipients array without a count limit and calls decrypt_cek() for every entry. An unauthenticated attacker who can submit a JWE to an endpoint using an RSA key-management algorithm can choose the number of private-key decryption operations performed by one request. The verify_all_recipients option does not reduce this work because the affected loop processes every recipient before consulting that setting, allowing repeated requests to exhaust service CPU without affecting confidentiality or integrity. This issue is fixed in version 1.7.5.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-119283?


## How do I fix CVE-2026-119283?

No fix has been published for CVE-2026-119283 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119283 being exploited?

There is no known exploitation of CVE-2026-119283 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119283 and fix it if it is affected.

What it is: CVE-2026-119283 is a high-severity vulnerability in authlib joserfc, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119283 in the wild and no public exploit code.

Affected product: authlib joserfc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119283/ (Markdown: https://insights.sbomify.com/CVE-2026-119283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119283
- OSV: https://osv.dev/vulnerability/CVE-2026-119283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119283/
Summaries are generated and may contain mistakes; the official description above is the record.
