# CVE-2026-119284: joserfc: Compact JWS size guard allocates attacker-controlled segments before rejection


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026

## What is CVE-2026-119284?

CVE-2026-119284 is a medium-severity vulnerability in authlib joserfc, published on 29 Oct 2026. 

### Official description

joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. Prior to 1.7.6, joserfc compact JWS deserialization calls bytes.split() before enforcing the existing aggregate segment-size limits. When attacker-controlled compact serialization bytes reach deserialize_compact(), the split creates copies of the header, payload, and signature segments before ExceededSizeError rejects them, causing an additional allocation approximately proportional to the supplied token. Requests that exhaust available process memory can therefore cause an availability failure even though signature verification fails. This issue is fixed in version 1.7.6.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-119284?


## How do I fix CVE-2026-119284?

No fix has been published for CVE-2026-119284 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-119284 being exploited?

There is no known exploitation of CVE-2026-119284 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-119284 and fix it if it is affected.

What it is: CVE-2026-119284 is a medium-severity vulnerability in authlib joserfc, published on 29 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-119284 in the wild and no public exploit code.

Affected product: authlib joserfc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-119284/ (Markdown: https://insights.sbomify.com/CVE-2026-119284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-119284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-119284
- OSV: https://osv.dev/vulnerability/CVE-2026-119284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-119284/
Summaries are generated and may contain mistakes; the official description above is the record.
