CVE-2026-11941 Use-after-free in connection ID iterator and FFI functions

Medium 5.6 Published Updated

Applications using disabled-by-default FFI functions in Quiche may crash or leak memory due to use-after-free errors.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-11941?

CVE-2026-11941 is a medium-severity use after free vulnerability in Cloudflare Quiche, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Cloudflare Quiche was affected by 2 use-after-free vulnerabilities in the connection ID iterator FFI functions.

The “quiche_connection_id_iter_next” and “quiche_conn_retired_scid_next” functions would return a pointer to a “ConnectionId” to the applications via function arguments, but the owned “ConnectionId” would be dropped at the end of those functions' scope.

Only applications using those FFI functions are affected. The FFI API is disabled by default by a build-time feature flag.

Impact If unpatched, an application calling the affected FFI functions will dereference freed memory. The most likely outcome is undefined behavior leading to a process crash (denial of service). Depending on allocator state, the read may also return adjacent heap contents, resulting in limited information disclosure or incorrect connection identifier handling.

Mitigation Users are requested to upgrade to quiche 0.29.2 which is the earliest version containing the fix for this issue.

Weakness: CWE-416

Which versions are affected by CVE-2026-11941?

2 open source packages ship an affected version, including quiche.

PackageAffectedFixed in
quiche crates.ioFrom 0.20.00.29.2
quiche crates.ioFrom 0.20.00.29.2

How do I fix CVE-2026-11941?

Upgrade quiche to 0.29.2 or later.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2026-11941 being exploited?

There is no known exploitation of CVE-2026-11941 in the wild and no public exploit code.

Sources

Also known as GHSA-mh64-ph39-mrc9.

Is CVE-2026-11941 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free