# CVE-2026-11986: Keycloak Admin UI REST Extensions: bulk role-removal endpoints fail to perform granular permission checks

> Delegated administrators can bypass permission checks to remove privileged roles from other users, disrupting access control in Keycloak.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-keycloak-2026-11986, ECHO-673a-913b-24a1, GHSA-6w3v-mcfh-m3q7, MINI-8fgc-r49c-hf47, MINI-vv4r-7phv-9h4h

## What is CVE-2026-11986?

CVE-2026-11986 is a medium-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 11 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in the admin-ui-ext component of Keycloak, which provides extended administrative user interface capabilities. The issue occurs because certain bulk role-removal endpoints fail to perform granular permission checks when deleting role mappings. This allows a delegated administrator with limited permissions to remove highly privileged roles from other users or groups, potentially disrupting administrative access control.

Weakness: CWE-425 (Direct Request)

## Which versions are affected by CVE-2026-11986?

3 open source packages ship an affected version, including org.keycloak:keycloak-rest-admin-ui-ext and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-rest-admin-ui-ext` | Maven | All versions | 26.7.0 |
| `org.keycloak:keycloak-rest-admin-ui-ext` | Maven | All versions | 26.7.0 |
| `keycloak` | Bitnami | From 26.6.0 | 26.6.5 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-11986?

Upgrade org.keycloak:keycloak-rest-admin-ui-ext to 26.7.0 or later.

## Is CVE-2026-11986 being exploited?

There is no known exploitation of CVE-2026-11986 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11986 and fix it if it is affected.

What it is: CVE-2026-11986 is a medium-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 11 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-11986 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-rest-admin-ui-ext (Maven): affected all versions; fixed in 26.7.0
- org.keycloak:keycloak-rest-admin-ui-ext (Maven): affected all versions; fixed in 26.7.0
- keycloak (Bitnami): affected from 26.6.0; fixed in 26.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11986/ (Markdown: https://insights.sbomify.com/CVE-2026-11986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11986
- OSV: https://osv.dev/vulnerability/CVE-2026-11986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11986/
Summaries are generated and may contain mistakes; the official description above is the record.
