{"answers":{"affected":"2 open source packages ship an affected version, including angular.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11998 exists.","fix":"Product is end of life, replace it.","what":"CVE-2026-11998 is a high-severity cross-site scripting vulnerability in Google AngularJS, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-11998 and fix it if it is affected.\n\nWhat it is: CVE-2026-11998 is a high-severity cross-site scripting vulnerability in Google AngularJS, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11998 exists.\n\nAffected packages and fixed versions:\n- angular (npm): affected from 1.2.0-rc.3 up to 1.8.3; no fix listed\n- angular (npm): affected from 1.2.0-rc.3 up to 1.8.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-11998/ (Markdown: https://insights.sbomify.com/CVE-2026-11998/index.md)","id":"CVE-2026-11998","markdown":"https://insights.sbomify.com/CVE-2026-11998/index.md","name":"CVE-2026-11998","record":{"aliases":["CLSA-2026-1784769553","CLSA-2026-1784769554","CLSA-2026-1784769558","CLSA-2026-1784769564","CLSA-2026-1784769597","DEBIAN-CVE-2026-11998","GHSA-7x27-g8rg-x87w","ROOT-APP-NPM-CVE-2026-11998","UBUNTU-CVE-2026-11998"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AngularJS library","requires_auth":"none","summary":"Attacker can execute arbitrary JavaScript in victim's browser by bypassing AngularJS SCE resource URL sanitization policies.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HeroDevs","cpe":[],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-791","name":"Incomplete Filtering of Special Elements"}],"description":"A flaw in AngularJS' Strict Contextual Escaping (SCE) logic allows bypassing certain SCE policies for resource URLs and can lead to arbitrary JavaScript execution within the context of the victim's browser session.\n\nSCE's purpose is to ensure that only trusted or safe values are used in certain security-sensitive contexts, such as resource URLs, including URLs that define executable JavaScript scripts, '\u003ciframe\u003e' documents, route templates, etc. A flaw in the logic that tries to match entire URLs against regular expression matchers can result in partial matches for certain types of regular expressions, effectively bypassing the policies and allowing the use of unsafe values as resource URLs.\n\nThis issue affects AngularJS versions greater than or equal to 1.2.0-rc.3.\n\nNote:\nThe AngularJS project was already End-of-Life when this CVE was published and will not receive any updates to address this issue. For more information see the  End-of-Life announcement https://docs.angularjs.org/misc/version-support-status .","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"AngularJS XSS via SCE resource URL sanitization bypass","id":"CVE-2026-11998","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"X.509 trust-chain bypass via path-depth exhaustion in wolfSSL_X509_verify_cert()","id":"CVE-2026-11999"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["1.2.0-rc.3"],"last_affected":["1.8.3"],"package":"angular","purl":null,"source":"GHSA-7x27-g8rg-x87w"},{"ecosystem":"npm","fixed":[],"introduced":["1.2.0-rc.3"],"last_affected":["1.8.3"],"package":"angular","purl":"pkg:npm/angular","source":"GHSA-7x27-g8rg-x87w"}],"prev":{"headline":"Bulk SEO Image \u003c= 1.1 - Cross-Site Request Forgery to Settings Update","id":"CVE-2026-11997"},"products":["AngularJS"],"published":"2026-06-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["Google"]},"summary":"Attacker can execute arbitrary JavaScript in victim's browser by bypassing AngularJS SCE resource URL sanitization policies.","url":"https://insights.sbomify.com/CVE-2026-11998/"}