# CVE-2026-1207: Potential SQL injection via raster lookups on PostGIS

> Remote attackers can inject SQL via the band index parameter in PostGIS raster lookups, potentially compromising database integrity and confidentiality.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-django-2026-1207, CLSA-2026-1787028657, CLSA-2026-1787220902, DEBIAN-CVE-2026-1207, ECHO-37cc-2ae7-e3c8, GHSA-mwm9-4648-f68q, MINI-6w4q-966q-jfq7, PYSEC-2026-44

## What is CVE-2026-1207?

CVE-2026-1207 is a medium-severity SQL injection vulnerability in Djangoproject Django, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28.
Raster lookups on ``RasterField`` (only implemented on PostGIS) allows remote attackers to inject SQL via the band index parameter.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Tarek Nakkouch for reporting this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-1207?

8 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 4.2.0 | 4.2.28, 5.2.11, 6.0.2 |
| `django` | PyPI | From 4.2 | 4.2.28, 5.2.11, 6.0.2 |
| `django` | PyPI | From 4.2a1 | 4.2.28 |
| `django` | PyPI | From 5.2a1 | 5.2.11 |
| `django` | PyPI | From 6.0a1 | 6.0.2 |
| `Django` | PyPI | From 4.2a1 | 4.2.28 |
| `Django` | PyPI | From 5.2a1 | 5.2.11 |
| `Django` | PyPI | From 6.0a1 | 6.0.2 |

Products: Djangoproject Django.

## How do I fix CVE-2026-1207?

Upgrade django to a fixed version for your release line: 4.2.28, 5.2.11 or 6.0.2.

## Is CVE-2026-1207 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1207 exists.

Public exploit code:

- Django 框架在使用 PostGIS 查询地理栅格（raster）数据时，若将未经验证的用户输入直接作为 band index（波段索引）参数，会引发 SQL 注入 (github_poc): https://github.com/sw0rd1ight/CVE-2026-1207
- Django RasterField - SQL Injection (nuclei): http/cves/2026/CVE-2026-1207.yaml

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1207 and fix it if it is affected.

What it is: CVE-2026-1207 is a medium-severity SQL injection vulnerability in Djangoproject Django, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-1207 exists.

Affected packages and fixed versions:
- django (Bitnami): affected from 4.2.0; fixed in 4.2.28, 5.2.11, 6.0.2
- django (PyPI): affected from 4.2; fixed in 4.2.28, 5.2.11, 6.0.2
- django (PyPI): affected from 4.2a1; fixed in 4.2.28
- django (PyPI): affected from 5.2a1; fixed in 5.2.11
- django (PyPI): affected from 6.0a1; fixed in 6.0.2
- Django (PyPI): affected from 4.2a1; fixed in 4.2.28
- Django (PyPI): affected from 5.2a1; fixed in 5.2.11
- Django (PyPI): affected from 6.0a1; fixed in 6.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1207/ (Markdown: https://insights.sbomify.com/CVE-2026-1207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1207
- OSV: https://osv.dev/vulnerability/CVE-2026-1207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1207/
Summaries are generated and may contain mistakes; the official description above is the record.
