# CVE-2026-1213: Askbot 0.12.2 - Insecure Direct Object Reference (IDOR)

> Authenticated users can modify other users' profile pictures due to missing authorization checks in Askbot.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-r2jv-fwfr-4j8c, PYSEC-2026-1193

## What is CVE-2026-1213?

CVE-2026-1213 is a medium-severity missing authorization vulnerability in askbot, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

All versions of askbot before and including 0.12.2 allow an attacker authenticated with normal user permissions to modify the profile picture of other application users.This issue affects askbot: 0.12.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-1213?

3 open source packages ship an affected version, including askbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `askbot` | PyPI | All versions | 0.12.3 |
| `askbot` | PyPI | All versions | 0.12.3 |
| `askbot` | PyPI | All versions | 0.12.3 |

Products: Askbot Askbot.

## How do I fix CVE-2026-1213?

Upgrade askbot to 0.12.3 or later.

## Is CVE-2026-1213 being exploited?

There is no known exploitation of CVE-2026-1213 in the wild and no public exploit code.

## Other vulnerabilities in askbot

- [CVE-2015-3169](https://insights.sbomify.com/CVE-2015-3169/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2014-2235](https://insights.sbomify.com/CVE-2014-2235/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2014-2236](https://insights.sbomify.com/CVE-2014-2236/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1213 and fix it if it is affected.

What it is: CVE-2026-1213 is a medium-severity missing authorization vulnerability in askbot, published on 27 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1213 in the wild and no public exploit code.

Affected packages and fixed versions:
- askbot (PyPI): affected all versions; fixed in 0.12.3
- askbot (PyPI): affected all versions; fixed in 0.12.3
- askbot (PyPI): affected all versions; fixed in 0.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1213/ (Markdown: https://insights.sbomify.com/CVE-2026-1213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1213
- OSV: https://osv.dev/vulnerability/CVE-2026-1213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1213/
Summaries are generated and may contain mistakes; the official description above is the record.
