{"answers":{"affected":"2 open source packages ship an affected version, including yoast/duplicate-post.","exploited":"There is no known exploitation of CVE-2026-1217 in the wild and no public exploit code.","fix":"Upgrade yoast/duplicate-post to 4.6 or later.","what":"CVE-2026-1217 is a medium-severity missing authorization vulnerability in Yoast Duplicate Post, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-1217 and fix it if it is affected.\n\nWhat it is: CVE-2026-1217 is a medium-severity missing authorization vulnerability in Yoast Duplicate Post, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-1217 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yoast/duplicate-post (Packagist): affected all versions; fixed in 4.6\n- yoast/duplicate-post (Packagist): affected all versions; fixed in 4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-1217/ (Markdown: https://insights.sbomify.com/CVE-2026-1217/index.md)","id":"CVE-2026-1217","markdown":"https://insights.sbomify.com/CVE-2026-1217/index.md","name":"CVE-2026-1217","record":{"aliases":["GHSA-g9w4-m5fx-x3wv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can duplicate or overwrite arbitrary posts, including private ones, due to missing capability checks in the Yoast Duplicate Post plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite \u0026 Republish feature to overwrite any published post with their own content.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yoast Duplicate Post has an Authenticated (Contributor+) Missing Authorization to Arbitrary Post Duplication and Overwrite","id":"CVE-2026-1217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"XML external entity in Zhiyou ERP","id":"CVE-2026-1218"},"packages":[{"ecosystem":"Packagist","fixed":["4.6"],"introduced":["0"],"last_affected":[],"package":"yoast/duplicate-post","purl":null,"source":"GHSA-g9w4-m5fx-x3wv"},{"ecosystem":"Packagist","fixed":["4.6"],"introduced":["0"],"last_affected":[],"package":"yoast/duplicate-post","purl":"pkg:composer/yoast/duplicate-post","source":"GHSA-g9w4-m5fx-x3wv"}],"prev":{"headline":"RSS Aggregator \u003c= 5.0.10 - Reflected Cross-Site Scripting via 'template' Parameter","id":"CVE-2026-1216"},"products":["Yoast Duplicate Post"],"published":"2026-03-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["yoast"]},"summary":"Authenticated attackers can duplicate or overwrite arbitrary posts, including private ones, due to missing capability checks in the Yoast Duplicate Post plugin.","url":"https://insights.sbomify.com/CVE-2026-1217/"}