# CVE-2026-1217: Yoast Duplicate Post has an Authenticated (Contributor+) Missing Authorization to Arbitrary Post Duplication and Overwrite

> Authenticated attackers can duplicate or overwrite arbitrary posts, including private ones, due to missing capability checks in the Yoast Duplicate Post plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-g9w4-m5fx-x3wv

## What is CVE-2026-1217?

CVE-2026-1217 is a medium-severity missing authorization vulnerability in Yoast Duplicate Post, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite & Republish feature to overwrite any published post with their own content.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-1217?

2 open source packages ship an affected version, including yoast/duplicate-post.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yoast/duplicate-post` | Packagist | All versions | 4.6 |
| `yoast/duplicate-post` | Packagist | All versions | 4.6 |

## How do I fix CVE-2026-1217?

Upgrade yoast/duplicate-post to 4.6 or later.

## Is CVE-2026-1217 being exploited?

There is no known exploitation of CVE-2026-1217 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-1217 and fix it if it is affected.

What it is: CVE-2026-1217 is a medium-severity missing authorization vulnerability in Yoast Duplicate Post, published on 18 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-1217 in the wild and no public exploit code.

Affected packages and fixed versions:
- yoast/duplicate-post (Packagist): affected all versions; fixed in 4.6
- yoast/duplicate-post (Packagist): affected all versions; fixed in 4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-1217/ (Markdown: https://insights.sbomify.com/CVE-2026-1217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-1217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-1217
- OSV: https://osv.dev/vulnerability/CVE-2026-1217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-1217/
Summaries are generated and may contain mistakes; the official description above is the record.
