# CVE-2026-12210: universal-tool-calling-protocol python-utcp utcp-gql/utcp-websocket server-side request forgery

> Remote attackers can exploit a server-side request forgery flaw in the utcp-gql/utcp-websocket component of the python-utcp library to access internal resources.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** GHSA-ppx3-28rw-8fpf, PYSEC-2026-3931, PYSEC-2026-3932

## What is CVE-2026-12210?

CVE-2026-12210 is a medium-severity server-side request forgery vulnerability in universal-tool-calling-protocol python-utcp, published on 15 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was detected in universal-tool-calling-protocol python-utcp 1.1.0. This affects an unknown function of the component utcp-gql/utcp-websocket. Performing a manipulation results in server-side request forgery. The attack can be initiated remotely. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-12210?

6 open source packages ship an affected version, including utcp-gql and utcp-websocket.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `utcp-gql` | PyPI | All versions | 1.1.1 |
| `utcp-gql` | PyPI | All versions | 1.1.1 |
| `utcp-gql` | PyPI | All versions | 1.1.1 |
| `utcp-websocket` | PyPI | All versions | 1.1.1 |
| `utcp-websocket` | PyPI | All versions | 1.1.1 |
| `utcp-websocket` | PyPI | All versions | 1.1.1 |

## How do I fix CVE-2026-12210?

Upgrade utcp-gql to 1.1.1 or later.

## Is CVE-2026-12210 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12210 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-12210 and fix it if it is affected.

What it is: CVE-2026-12210 is a medium-severity server-side request forgery vulnerability in universal-tool-calling-protocol python-utcp, published on 15 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-12210 exists.

Affected packages and fixed versions:
- utcp-gql (PyPI): affected all versions; fixed in 1.1.1
- utcp-gql (PyPI): affected all versions; fixed in 1.1.1
- utcp-gql (PyPI): affected all versions; fixed in 1.1.1
- utcp-websocket (PyPI): affected all versions; fixed in 1.1.1
- utcp-websocket (PyPI): affected all versions; fixed in 1.1.1
- utcp-websocket (PyPI): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-12210/ (Markdown: https://insights.sbomify.com/CVE-2026-12210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-12210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-12210
- OSV: https://osv.dev/vulnerability/CVE-2026-12210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-12210/
Summaries are generated and may contain mistakes; the official description above is the record.
